Как в инструменте чертежник нарисовать снежинки? Я немного понимаю, норазобраться не могу, почему то не получается!Помогите пожалуйста! !!!!!По сколько брать вектор?

Где то штук 20- 30 и попробуй свою какуюто сообразить

Оцени ответ

использовать Чертежник
алг снежинки
нач
. нц 3 раз
. . | цикл рисования диагонального лучика от ноля по диагонали вверх
. . опустить перо
. . сместиться на вектор (2,2)
. . | рисуем лучик от ноля по диагонали вверх
. . поднять перо
. . сместиться на вектор (1,-2)
. . | смещаемся (не рисуя, т.к. перо поднято) на вектор (1,-2) от последней точки снежинки в точку начала повторного лучика
. кц
. сместиться в точку (0,1)
. | смещаемся в точку (0,1) от начала координат
. нц 3 раз
. . | цикл рисования горизонтального лучика
. . опустить перо
. . сместиться на вектор (2,0)
. . | рисуем лучик из (2.1) по горизонтали влево
. . поднять перо
. . сместиться на вектор (1,0)
. . | смещаемся (не рисуя, т.к. перо поднято) на вектор (1,0) от последней точки снежинки в точку начала повторного лучика
. кц
. сместиться в точку (0,2)
. нц 3 раз
. . | цикл рисования диагонального лучика по диагонали вниз - справа-налево
. . опустить перо
. . сместиться на вектор (2,-2)
. . | рисуем лучик из (0,2) по по диагонали вниз
. . поднять перо
. . сместиться на вектор (1,2)
. . | смещаемся (не рисуя, т.к. перо поднято) на вектор (1,2) от последней точки снежинки в точку начала повторного лучика
. кц
. сместиться в точку (1,0)
. нц 3 раз
. . | цикл рисования вертикального лучика
. . опустить перо
. . сместиться на вектор (0,2)
. . | рисуем лучик из (1.0) по вертикали вверх
. . поднять перо
. . сместиться на вектор (3,-2)
. . | смещаемся (не рисуя, т.к. перо поднято) на вектор (3,-2) от последней точки снежинки в точку начала повторного лучика
. кц
кон

Оцени ответ
Не нашёл ответ?

Если тебя не устраивает ответ или его нет, то попробуй воспользоваться поиском на сайте и найти похожие ответы по предмету Информатика.

Найти другие ответы

Загрузить картинку
Самые новые вопросы